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Introduction to R

� R is a free software environment for statistical computing and graphics.

� R is the most popular language in the world of Data Science.

� It is heavily used in analyzing data that is both structured and unstructured.

� This has made R, the standard language for performing statistical operations.

� R allows various features that set it apart from other Data Science languages.
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Why learn R?

� Free and open-source tool

� Large community of users

� Latest cutting edge technology

� Independent platform

� Gateway to lucrative career

� Robust visualization library

� Go to language for Statistics and Data Science

� Used in almost every industry
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Setup R environment

� It compiles and runs on a wide variety of UNIX platforms, Windows, and
MacOS.

� Download the R installer from https://cran.r-project.org/

� Run the installer and keep default settings.

� Must insure that you have admin rights. Without this, you will not be able to
install additional packages later.

� Usually, I prefer two approaches to setup R environment.
� Independent environment
� Anaconda environment
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From where to download R
� Download the R installer from https://cran.r-project.org/
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From where to download R
� Download the R installer from https://cran.r-project.org/

7/58 Dr. Kundan Kumar Foundation of Machine Learning (CSE4032)

https://cran.r-project.org/


Introduction Setup independent environment Setup Anaconda environment Start with RStudio References

From where to download R
� Download the R installer from https://cran.r-project.org/
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R installation guide
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R installation guide
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R installation guide
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R installation guide
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R installation guide

13/58 Dr. Kundan Kumar Foundation of Machine Learning (CSE4032)



Introduction Setup independent environment Setup Anaconda environment Start with RStudio References

R installation guide
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R installation guide
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R installation guide

� Don’t forget to set the path to use R from command prompt / terminal.
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Check R installation
� Type ‘r’ in Command Prompt to ensure that R is the path.
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Use R as a calculator
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From where to download RStudio

� Download the RStudio installer from
https://rstudio.com/products/rstudio/download/#download
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RStudio Installation guide
� Run RStudio-1.4.1106.exe as administrator.
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RStudio Installation guide
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RStudio Installation guide

22/58 Dr. Kundan Kumar Foundation of Machine Learning (CSE4032)



Introduction Setup independent environment Setup Anaconda environment Start with RStudio References

RStudio Installation guide
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RStudio Installation guide

24/58 Dr. Kundan Kumar Foundation of Machine Learning (CSE4032)



Introduction Setup independent environment Setup Anaconda environment Start with RStudio References

Introduction
� Anaconda is an open-source distribution for python and R.

� It is used for
� data science, data analytic,
� machine learning,
� deep learning, etc.

� More than 300 libraries are available for data science.
� Simplified package management and deployment.
� An easily manageable environment setup which can deploy any project with

the click of a single button.
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Where to find Anaconda?
1. Go to website: https://www.anaconda.org

2. Click on download on top-right corner and scroll down. 1
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Where to find Anaconda?
3. Scroll down and choose your operating system.
4. Download 64-Bit or 32-Bit Graphical Installer (Python 3.8 version).

4

3
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How to install Anaconda?
� In windows, double click the installer to run (you may choose run as

Administrator for safe side).
� Click on Next.
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How to install Anaconda?
� Click on I Agree.
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How to install Anaconda?
� Click on Next.
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How to install Anaconda?
� Click on Install.
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How to install Anaconda?
� Click on Next.
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How to install Anaconda?
� Click on Next, when it gets highlighted.
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How to install Anaconda?
� Click on Next.
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How to install Anaconda?
� Click on Finish.
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Open Anaconda Powershell Prompt

� Go to start (bottom-left corner) and scroll down to find Anaconda3 (64 bit).

� Click on Anaconda Powershell Promt to open it.
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Check, is anaconda in path?
� In the powershell prompt run “conda” to ensure that anaconda is in path.

$ conda
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How to create a virtual environment for R?

� To create a virtual environment for R, run

$ conda create -n R4 r-essentials r-base

� press Y to proceed. Wait for complete the installation.

� After the completion of the installation, activate the virtual environment as

$ conda activate R4

� Ensure that default environment base is changed to R4.

� To deactivate the environment

$ conda deactivate

NOTE: You can use up and down key in the keyboard to see command history
executed.
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How to create a virtual environment for Python?

� To create a virtual environment for python, run

$ conda create -n py36 python=3.6 anaconda

� press Y to proceed. Wait for complete the installation.

� After the completion of the installation, activate the virtual environment as

$ conda activate py36

� Ensure that default environment base is changed to py36.

� To deactivate the environment

$ conda deactivate

NOTE: You can use up and down key in the keyboard to see command history
executed.
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How to install and start RStudio

� Activate the virtual environment as

$ conda activate R4

� Ensure that default environment base is changed to R4.

� Install RStudio using following command in terminal

$ conda install -c r rstudio

� Similarly, other library/package/module can be installed.

� You can install packages manually from RStudio.

� You start RStudio from terminal

$ rstudio

� Alternatively, Jupyter notebook can be used to write your code in R or Python.
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How to switch between python and R?

� Deactivate environment if you are already in an environment.

� Then activate environment as per your coding platform.

� Start RStudio or Jupyter Notebook IDE as per you choice.
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RStudio screen
� RStudio allows the user to run R in a more user-friendly environment. It is

open-source (i.e. free).
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Workspace tab
� The workspace tab stores any object, value, function or anything you create

during your R session. In the example below, if you click on the dotted squares
you can see the data in specific window.

Workspace tab (1) 
The workspace tab stores any object, value, function or anything you create during your R 
session. In the example below, if you click on the dotted squares you can see the data on a 
screen to the left.  

DSS/OTR 

Showing here matrix B. To see matrix 
A click on the respective tab. 
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Workspace tab
� Here is another example on how the workspace looks like when more objects

are added. Notice that the data frame house.pets is formed from different
individual values or vectors.

Workspace tab (2) 

Here is another example on how the workspace looks like when more objects are added. 
Notice that the data frame house.pets is formed from different individual values or 
vectors. 

Click on the dotted square to look at the 
dataset in a spreadsheet form. 

DSS/OTR 
44/58 Dr. Kundan Kumar Foundation of Machine Learning (CSE4032)



Introduction Setup independent environment Setup Anaconda environment Start with RStudio References

History tab
� The history tab keeps a record of all previous commands. It helps when

testing and running processes. Here you can either save the whole list or you
can select the commands you want and send them to an R script to keep
track of your work.

� In this example, we select all and click on the “To Source” icon, a window on
the left will open with the list of commands. Make sure to save the ‘untitled1’
file as an *.R script.

History tab 

The history tab keeps a record of all previous commands. It helps when testing and running 
processes. Here you can either save the whole list or you can select the commands you want 
and send them to an R script to keep track of your work.  
In this example, we select all and click on the “To Source” icon, a window on the left will 
open with the list of commands. Make sure to save the ‘untitled1’ file as an *.R script. 

6 
DSS/OTR 
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Changing the working directoryChanging the working directory 

If you have different projects you can change the working 
directory for that session, see above. Or you can type: 
 
# Shows the working directory (wd) 

 
getwd() 

 

# Changes the wd 

 

setwd("C:/myfolder/data") 

 

 
 

1 

2 

3 

7 
DSS/OTR 
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Setting a default working directory
Setting a default working directory 

Every time you open RStudio, it goes to a 
default directory. You can change the 
default to a folder where you have your 
datafiles so you do not have to do it every 
time. In the menu go to Tools->Options 

1 

2 

3 

4 
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R script
� The usual RStudio screen has four windows:

1. Console.
2. Workspace/Environment and history.
3. Files, plots, packages and help.
4. The R script(s) and data view. The R script is where you keep a record of your

work.

R script (1) 

The usual Rstudio screen has four windows:  
1. Console. 
2. Workspace and history. 
3. Files, plots, packages and help. 
4. The R script(s) and data view. 

The R script is where you keep a record of your work. For Stata users this would be like the 
do-file, for SPSS users is like the syntax and for SAS users the SAS program. 
 

9 
DSS/OTR 
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R script
� To create a new R script you can either go to File → New → R Script, or

click on the icon with the “+” sign and select “R Script”, or simply press
Ctrl+Shift+N. Make sure to save the script.

R script (2) 

To create a new R script you can either go to File -> New -> R Script, or click on the 
icon with the “+” sign and select “R Script”, or simply press Ctrl+Shift+N. Make sure to save 
the script. 

Here you can type R commands and run them. Just 
leave the cursor anywhere on the line where the 
command is and press Ctrl-R or click on the ‘Run’ 
icon above. Output will appear in the console below. 
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Packages tab

� The package tab shows the list of add-ons included in the installation of
RStudio. If checked, the package is loaded into R, if not, any command
related to that package won’t work, you will need select it. You can also
install other add-ons by clicking on the ‘Install Packages’ icon.

� Another way to activate a package is by typing, for example,
library(foreign). This will automatically check the –foreign package (it
helps bring data from proprietary formats like Stata, SAS or SPSS).
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Packages tab

Packages tab 
The package tab shows the list of add-ons included in the installation of RStudio. If checked, 
the package is loaded into R, if not, any command related to that package won’t work, you 
will need select it. You can also install other add-ons by clicking on the ‘Install Packages’ icon. 
Another way to activate a package is by typing, for example, library(foreign). This 
will automatically check the --foreign package (it helps bring data from proprietary 
formats like Stata, SAS or SPSS). 

11 
DSS/OTR 
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Installing a package
Installing a package 

We are going to install the package –
rgl (useful to plot 3D images). It 
does not come with the original R 
install.  
Click on “Install Packages”, 
write the name in the pop-up 
window and click on “Install”. 

Before 

3 

2 

1 

After 
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Plots tab Plots tab (1) 

The plots tab will display the graphs. 
The one shown here is created by 
the command on line 7 in the script 
above.  
See next slide to see what happens 
when you have more than one graph  

13 
DSS/OTR 
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Plots tab Plots tab (2) 

Here there is a second graph (see 
line 11 above). If you want to see the 
first one, click on the left-arrow icon.  

14 
DSS/OTR 
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Plots tab - Graphs export

Plots tab (3) – Graphs export 
To extract the graph, click on “Export” where you can save the file as an image (PNG, JPG, 
etc.) or as PDF, these options are useful when you only want to share the graph or use it in a 
LaTeX document. Probably, the easiest way to export a graph is by copying it to the clipboard 
and then paste it directly into your Word document.  

Make sure to select ‘Metafile’ 

1 

2 

Paste it into your Word document 

3 

4 
5 
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Plots tab - 3D graphs 3D graphs 

3D graphs will display on a separate 
screen (see line 15 above). You won’t 
be able to save it, but after moving it 
around, once you find the angle you 
want, you can screenshot it and paste 
it to you Word document. 
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References

Introduction to RStudio, https://dss.princeton.edu/training/RStudio101.pdf

The Comprehensive R Archive Network, https://cran.r-project.org/

RStudio Desktop,
https://www.rstudio.com/products/rstudio/download/#download

Anaconda, Where packages, notebooks, projects and environments are shared,
https://www.anaconda.com/products/individual
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